您当前的位置:指标吧飞狐指标

源码-波浪理论源码(波浪)

时间:2009-03-01 07:50:57 飞狐指标公式,飞狐指标公式,飞狐公式破解
摘要: DRAWGBKLAST(close>0,STRIP(RGB(0,128,128),RGB(25,25,112),0));TT:=VOL/TICKCOUNT;TT10:=ma(TT,10);TT60:=(ma(TT,60));ma10:=ma(c,10);ma60:=ma(c,60);aa:=-(TT10-TT60);bb:=ma10>=ma60;cc:=aa>=0 and bb;STICKLINE(aa<0,0,aa,8.10,0),colorgreen;{股票公式-股票公式网站 www.GupAng.com}STICKLINE(cc ...走强,买点,处暑,小暑,芒种波浪理论源码波浪 源码 理论pl5:=ZIG(3,5);en1:=ZIG(3,5)>REF(ZIG(3,5),1) and REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) and REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);ex1:=ZIG(3,5)=REF(ZIG(3,5),2) and REF(ZIG(3,5),2)>

pl5:=ZIG(3,5);
en1:=ZIG(3,5)>REF(ZIG(3,5),1) and REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) and REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
ex1:=ZIG(3,5)<REF(ZIG(3,5),1) and REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) and REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
pl10:=ZIG(3,13);
en2:=ZIG(3,10)>REF(ZIG(3,10),1) and REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) and REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
ex2:=ZIG(3,10)<REF(ZIG(3,10),1) and REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) and REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
pl20:=ZIG(3,26);
en3:=ZIG(3,20)>REF(ZIG(3,20),1) and REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) and REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
ex3:=ZIG(3,20)<REF(ZIG(3,20),1) and REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) and REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
pl40:=ZIG(3,55);
走强1:=BARSLAST(pl5<REF(pl5,1));
走弱1:=BARSLAST(pl5>REF(pl5,1));
走强2:=BARSLAST(pl10<REF(pl10,1));
走弱2:=BARSLAST(pl10>REF(pl10,1));
走强3:=BARSLAST(pl20<REF(pl20,1));
走弱3:=BARSLAST(pl20>REF(pl20,1));
ztjz5:=IF(pl10>REF(pl10,1),COUNT(en1,走强2),0);
ztjd5:=IF(pl10>REF(pl10,1),COUNT(ex1,走强2),0);
dtjz5:=IF(pl10<REF(pl10,1),COUNT(en1,走弱2),0);
dtjd5:=IF(pl10<REF(pl10,1),COUNT(ex1,走弱2),0);
ztjz10:=IF(pl20>REF(pl20,1),COUNT(en2,走强3),0);
ztjd10:=IF(pl20>REF(pl20,1),COUNT(ex2,走强3),0);
dtjz10:=IF(pl20<REF(pl20,1),COUNT(en2,走弱3),0);
dtjd10:=IF(pl20<REF(pl20,1),COUNT(ex2,走弱3),0);
DRAWTEXT(en1 and dtjz5=1,LOW*0.98,'(Ⅰ)'),colorffff00;
DRAWTEXT(ex1 and dtjd5=2,HIGH*1.02,'(Ⅱ)'),colorffff00;
DRAWTEXT(en2 and ztjz5=1,LOW*0.98,'(Ⅲ)'),colorffff00;
DRAWTEXT(ex1 and pl10>REF(pl10,1) and ztjd5=1,HIGH*1.02,'⑴'),colorff;
DRAWTEXT(en1 and pl10>REF(pl10,1) and ztjz5=2,LOW*0.98,'⑵'),colorff;
DRAWTEXT(ex1 and pl10>REF(pl10,1) and ztjz5=2,HIGH*1.02,'⑶'),colorff;
DRAWTEXT(en1 and pl10>REF(pl10,1) and ztjz5=3,LOW*0.98,'⑷'),colorff;
DRAWTEXT(ex2 and pl20>REF(pl20,1) and ztjd10=1,HIGH*1.02,'⑸'),colorff;
DRAWTEXT(en2 and dtjz10=1,LOW*0.94,'【A】'),color00ff00;
DRAWTEXT(ex2 and dtjd10=2,HIGH*1.03,'【B】'),color00ff00;
DRAWTEXT(en3 and ztjz10=1,LOW*0.94,'【C】'),color00ff00;
DRAWTEXT(ex2 and pl20>REF(pl20,1) and ztjd10=1,HIGH*1.04,'①'),Linethick3,colorffff;
DRAWTEXT(en2 and pl20>REF(pl20,1) and ztjz10=2,LOW*0.94,'②'),Linethick3,colorffff;
DRAWTEXT(ex2 and pl20>REF(pl20,1) and ztjd10=2 or (ztjd10=0 or ztjd10=2) and ex2,HIGH*1.04,'③'),Linethick3,colorffff;
DRAWTEXT(en2 and pl20>REF(pl20,1) and ztjz10=3,LOW*0.94,'④'),Linethick3,colorffff;
DMLJ:=HHV(HIGH,120);


TY:=CLOSE;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A:=REF(CLOSE,BARSLAST(HD));
B:=REF(CLOSE,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波浪顶:IF(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK4;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
波浪底:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK4;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS(CLOSE-REF(CLOSE,1)),7)*100;
VAR9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS(CLOSE-REF(CLOSE,1)),13)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGH(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
买点1:=VAR10;
买点2:=(VAR11+VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;
VAR22:=买点1 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);
VAR1:=MA(CLOSE,6);
VAR2:=MA(CLOSE,18);
VAR31:=MA(CLOSE,30);
VARB1:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC1:=INTPART(VARB1*100)/100;
VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE1:=EMA(VARD1,9);
VAR131:=REF(VARE1,1);
VAR141:=VARE1;
VAR151:=VAR141-VAR131;
VAR161:=REF(VARD1,1);
VAR171:=VARD1;
VAR181:=VAR171-VAR161;
VAR191:=OPEN;
VAR1A1:=CLOSE;
DRAWTEXT(买点1>0,LOW-0.01,'▲买!'),COLORRED;
DRAWTEXT(买点2>0,LOW-0.01,'▲买入要涨了'),COLORYELLOW;
DRAWTEXT(卖点1>0,HIGH+0.1,'▼快卖要跌了'), COLORWHITE;


a:=BARSCOUNT(CLOSE);
ah:=HHV(HIGH,72);
al:=LLV(LOW,72);
a0:=(ah-al)/21;
b1:=LOW-a0;
DRAWTEXT((a+0)/15=FLOOR((a+0)/15),b1-2.5*a0,'▲时窗'),COLORWHITE;

var31:=HHVBARS(ZIG(3, 19)>REF(ZIG(3,19),1)
and REF(ZIG(3,19), 1)<REF(ZIG(3,19), 2),0);
STICKLINE(var31=2,LOW*0.95,LOW*0.98,8,0),color0000ff;
DRAWTEXT(var31=2,LOW*0.95,'3天'),COLORWHITE;
STICKLINE(var31=4,HIGH*1.05,HIGH*1.02,8,0),color9966ff;
DRAWTEXT(var31=4,HIGH*1.06,'5天'),COLORWHITE;
STICKLINE(var31=7,LOW*0.95,LOW*0.98,8,0),color00ffff;
DRAWTEXT(var31=7,LOW*0.95,'8天'),COLORWHITE;
STICKLINE(var31=12,HIGH*1.05,HIGH*1.02,8,0),colorff33ff;
DRAWTEXT(var31=12,HIGH*1.06,'13天'),COLORWHITE;
STICKLINE(var31=20,LOW*0.95,LOW*0.98,8,0),color0066ff;
DRAWTEXT(var31=20,LOW*0.95,'21天'),COLORWHITE;
STICKLINE(var31=33,HIGH*1.05,HIGH*1.02,8,0),colorffff00;
DRAWTEXT(var31=33,HIGH*1.06,'34天'),COLORWHITE;
STICKLINE(var31=54,LOW*0.95,LOW*0.98,8,0),COLORWHITE;
DRAWTEXT(var31=54,LOW*0.95,'55天'),COLORWHITE;
STICKLINE(var31=88,HIGH*1.05,HIGH*1.02,8,0),color00ff00;
DRAWTEXT(var31=88,HIGH*1.06,'89天'),COLORWHITE;
STICKLINE(var31=143,LOW*0.95,LOW*0.98,8,0),colorccffff;
DRAWTEXT(var31=143,LOW*0.95,'144天'),COLORWHITE;
STICKLINE(var31=232 ,HIGH*1.05,HIGH*1.02,8,0),colorff0033;
DRAWTEXT(var31=232,HIGH*1.06,'233天'),COLORWHITE;
STICKLINE(var31=376,LOW*0.95,LOW*0.98,8,0),colorff9966;
DRAWTEXT(var31=376,LOW*0.95,'377天'),COLORWHITE;

立春:=FILTER(MONTH=2 AND (DAY=3  OR DAY=5 ),2);
雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
惊蛰:=FILTER(MONTH=3 AND (DAY=5  OR DAY=7 ),2);
春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
清明:=FILTER(MONTH=4 AND (DAY=3  OR DAY=6 ),2);
谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
立夏:=FILTER(MONTH=5 AND (DAY=6  OR DAY=8 ),2);
小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
芒种:=FILTER(MONTH=6 AND (DAY=5  OR DAY=7 ),2);
夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
小暑:=FILTER(MONTH=7 AND (DAY=6  OR DAY=8 ),2);
大署:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
立秋:=FILTER(MONTH=8 AND (DAY=7  OR DAY=9 ),2);
处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
白露:=FILTER(MONTH=9 AND (DAY=7  OR DAY=9 ),2);
秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
寒露:=FILTER(MONTH=10 AND (DAY=7  OR DAY=9 ),2);
霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
立冬:=FILTER(MONTH=11 AND (DAY=7  OR DAY=9 ),2);
小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
大雪:=FILTER(MONTH=12 AND (DAY=6  OR DAY=8 ),2);
冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
小寒:=FILTER(MONTH=1 AND (DAY=5  OR DAY=7 ),2);
大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);


DRAWTEXT(立春,HIGH*1.02,'立春'),COLORgreen,ALIGN1;
DRAWTEXT(雨水,HIGH*1.02,'雨水'),COLORgreen,ALIGN1;
DRAWTEXT(惊蛰,HIGH*1.02,'惊蛰'),COLORgreen,ALIGN1;
DRAWTEXT(春分,HIGH*1.02,'春分'),COLORgreen,ALIGN1;
DRAWTEXT(清明,HIGH*1.02,'清明'),COLORgreen,ALIGN1;
DRAWTEXT(谷雨,HIGH*1.02,'谷雨'),COLORgreen,ALIGN1;
DRAWTEXT(立夏,HIGH*1.02,'立夏'),COLORMAGENTA,ALIGN1;
DRAWTEXT(小满,HIGH*1.02,'小满'),COLORMAGENTA,ALIGN1;
DRAWTEXT(芒种,HIGH*1.02,'芒种'),COLORMAGENTA,ALIGN1;
DRAWTEXT(夏至,HIGH*1.02,'夏至'),COLORMAGENTA,ALIGN1;
DRAWTEXT(小暑,HIGH*1.02,'小暑'),COLORMAGENTA,ALIGN1;
DRAWTEXT(大署,HIGH*1.02,'大署'),COLORMAGENTA,ALIGN1;
DRAWTEXT(立秋,HIGH*1.02,'立秋'),COLORYELLOW,ALIGN1;
DRAWTEXT(处暑,HIGH*1.02,'处暑'),COLORYELLOW,ALIGN1;
DRAWTEXT(白露,HIGH*1.02,'白露'),COLORYELLOW,ALIGN1;
DRAWTEXT(秋分,HIGH*1.02,'秋分'),COLORYELLOW,ALIGN1;
DRAWTEXT(寒露,HIGH*1.02,'寒露'),COLORYELLOW,ALIGN1;
DRAWTEXT(霜降,HIGH*1.02,'霜降'),COLORYELLOW,ALIGN1;
DRAWTEXT(立冬,HIGH*1.02,'立冬'),COLORWHITE,ALIGN1;
DRAWTEXT(小雪,HIGH*1.02,'小雪'),COLORWHITE,ALIGN1;
DRAWTEXT(大雪,HIGH*1.02,'大雪'),COLORWHITE,ALIGN1;
DRAWTEXT(冬至,HIGH*1.02,'冬至'),COLORWHITE,ALIGN1;
DRAWTEXT(小寒,HIGH*1.02,'小寒'),COLORWHITE,ALIGN1;
DRAWTEXT(大寒,HIGH*1.02,'大寒'),COLORWHITE,ALIGN1;

{点击看本软件截图:分.析家公 式网 http://www、gongshi8、com 整理}

  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:走强,买点,处暑,小暑,芒种
关键字:
相关阅读:
  • >>公式源码:买点指标(号称没有比它准的飞狐买点指标 副图 源码)(副图)
    VarC:=LOW; VarD:=REF(LOW,1); VarE:=SMA(ABS(VarC-VarD),3,1)/SMA(MAX(VarC-VarD,0),3,1)*100; VarF:=MA(VarE/10,3); Var10:=LLV(LOW,30); Var11:=HHV(VarF,30); MA(IF(LOW<=Var10,(VarF+Var11*2)/2,0),3);VAR1:=REF((LOW+OPEN+CLO...
  • >>源码-非常不错的主图(通达信)(主图)
    EMA13:EMA(C,13),COLORWHITE;EMA21:EMA(C,21),COLORYELLOW;EMA34:EMA(C,34),COLORFF00FF;EMA120:EMA(C,120),COLORFFCCCC;EMA250:MA(C,250),COLORFFCC66;X1:=(C+L+H)/3;X2:=EMA(X1,6);X3:=EMA(X2,5);STICKLINE(X2>X3 AND C>EMA13,LO...
  • >>公式-大智慧谷底淘金指标公式(谷底)
    拉升力:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,30)-LLV(LOW,36))*0.6*CLOSE;拉升力A:=SMA(拉升力,6.3,1);波峰波谷:SMA(拉升力A,3,1),COLORFFFFFF;拉升力B:=3*拉升力A-2.1*波峰波谷;空方:=3*波峰波谷-1* 拉升力A;做空:IF(空方>拉升力B,拉升力...
  • >>公式源码-机构MACD(机构)
    DIFF:(EMA(CLOSE,3) - EMA(CLOSE,13)),COLORRED;DEA:EMA(DIFF,9),COLORFF00FF;MACD:0.9*(DIFF-DEA), COLORSTICK;IF(DIFF<0,DIFF,0),COLORYELLOW,LINETHICK1;IF(DIFF<0,0,DIFF),COLORRED,LINETHICK1;IF(DIFF<DEA,DIFF,DEA),COLOR00FF00...


  • 友情链接: 庄家 | 宏旺电子 | 海口成人用品 | 股票入门 |5日线 |大智慧公式| 通达信指标公式 | 生活技巧 | 笑话 |