您当前的位置:指标吧大智慧指标

[指标]大智慧变色龙主图指标公式(主图)

时间:2011-05-25 11:56:34 大智慧指标公式,大智慧指标破解
摘要: 强势股(主升浪)Var1:=WINNER(CLOSE*0.900)*100;Var2:=VOL/CAPITAL*100;Var3:=Var1-Var2;Var4:=Var3>=10 AND Var3<25;Var5:=Var3>=25;强势股:=IF(Var4, 10, 0);主升浪:=IF(Var5, 15, 0);强势股选股:if(强势股=10 and c/ref(c,1)>1.03 and v>ref(v,1)*1.3,1,0);主升浪选股:if(主升浪=15 and c/ref(c,1)>1....买卖点,收盘价,明日,买点,市盈率大智慧变色龙主图指标公式主图 变色龙 公式 指标INPUT:M(10,1,30,1);止盈线:(MA(CLOSE,M) * 1.15),Color0000FF;分水岭:(MA(CLOSE,M) * 1),COLORWHITE;止损线:(MA(CLOSE,M) * 0.85),Color00FF80;总股本:=FINANCE2(35) ;流通股:=FINANCE2(37);限

INPUT:M(10,1,30,1);
止盈线:(MA(CLOSE,M) * 1.15),Color0000FF;
分水岭:(MA(CLOSE,M) * 1),COLORWHITE;
止损线:(MA(CLOSE,M) * 0.85),Color00FF80;
总股本:=FINANCE2(35) ;
流通股:=FINANCE2(37);
限售A股:=FINANCE2(41);
每股收益:=FINANCE2(3);
市盈率:=DYNAINFO(39);
每股公积金:=FINANCE2(7);
所属板块:=BKNAME;
DRAWTEXTABS(12,14, '所属板块: '+所属板块),COLORYELLOW;
DRAWTEXTABS(12,27,'每股收益: '+NUMTOSTRN(每股收益,3)+'元 利润增长:'+FINANCE2(10)+'% 市盈率:'+NUMTOSTRN(市盈率,1)+'倍 '+' 每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),COLORYELLOW;
DRAWTEXTABS(12,40,'总 股 本: '+NUMTOSTRN(总股本,2)+'万股'+' 流通A股:'+NUMTOSTRN(流通股,2)+'万股'+' 限售A股:'+NUMTOSTRN(限售A股,2)+'万股'),COLORYELLOW;
{17}
x9:FORCAST(c,9),Colorwhite,LINETHICK2;
llx:=llv(FORCAST(c,9),2);
DRAWGBKLAST(DYNAINFO(3)<DYNAINFO(7){OPEN},STRIP(RGB(0,150,0),RGB(150,0,0),1));
DRAWGBKLAST({CLOSE}DYNAINFO(3)>DYNAINFO(7){OPEN},STRIP(RGB(150,0,0),RGB(0,150,0),1));
DRAWTEXTREL(550,900,STKLABEL+' '+STKNAME+' '+DYNAINFO(7)+'元'+' '+DYNAINFO(14)*100+'%'),LINETHICK4,COLORFFFF00;
PARTLINE(x9,x9=llx,rgb(255,205,0),x9<>llx,rgb(255,0,0)),linethick4;
{24}
{柱图}
STICKLINE(c>=o and o<>0,HIGH,LOW,0.5,0),color0000CD;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,8,0),color070084;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,7,0),color0000A3;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,6,0),color0000B7;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,5,0),color0000CD;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,4,0),color0000E9;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,2,0),color0754E9;
STICKLINE(c>=o and o<>0,CLOSE,OPEN,0.5,0),Color68B8FF;
STICKLINE(c<o and o<>0,HIGH,LOW,0.5,0),colorFFBE00;
STICKLINE(CLOSE<OPEN and OPEN<>0,HIGH,LOW,0.5,0),colorFFBE00;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,8,0),ColorCA6500;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,7,0),ColorE17100;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,6,0),ColorF27900;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,5,0),ColorFF850B;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,4,0),ColorFF9326;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,2,0),ColorFFA851;
STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,0.5,0),colorFFFF00;
{43}
DRAWGBK(c,'7' );
Var3:=LLV(H,240);
Var4:=100*(C-Var3)/Var3;
Var5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
Var6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
{Var7:=0;}
Var8:=MA(HHV(C-REF(C,1),0),34)/MA(ABS(C-REF(C,1)),7)*100;
Var9:=MA(HHV(C-REF(C,1),0),13)/MA(ABS(C-REF(C,1)),13)*100;
VarA:=BARSCOUNT(C);
VarB:=Var8<20 AND Var9<23 AND VarA>35;
VarC:=VarB AND COUNT(VarB,1)=1;
VarD:=EMA(C,21)-EMA(C,8);
VarE:=EMA(VarD,5);
VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);
Var10:=IF(TROUGH(3,16,1)=0 AND H>L+0.04,4,0);
Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
Var12:=ZIG(3,6)<REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
Var13:=ZIG(3,22)>REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
Var14:=ZIG(3,22)<REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
Var15:=ZIG(3,51)>REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
Var16:=ZIG(3,51)<REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
Var19:=EMA(C,2)-EMA(C,150);
Var1A:=EMA(Var19,100);
Var1B:=2*(Var19-Var1A);
Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);
Var1D:=SQRT(SQRT(L*H*O*C));
Var1E:=EMA(Var1D*0.97,3);
Var1F:=(H+L+C)/3;
Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));
Var21:=CROSS(Var1E,L);
买点1:=Var10;
买点2:=(Var11+Var13+Var15+Var17);
卖点1:=(Var12+Var14+Var16+Var18);
{股票公式-股票公式网站 www.guPang.com}
Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4<0AND Var5=0 AND Var6=0 AND Var20<(-110);
DRAWTEXT(买点1>0,L-0.15,'B'),LINETHICK4,ALIGN1,colorred;{B}
DRAWTEXT(买点2>0,L-0.25,{'B'}'买'),LINETHICK4,ALIGN1,COLOR00FFFF;{B}
DRAWTEXT(卖点1>0,H+0.95,{'S'}'卖'),LINETHICK4,ALIGN1,COLOR33FF33;{S}
{83}
{十字光标提示}
a:="LTFunc6@FORLT2";
s1:="LTFunc6@LT_S1";
hs:="LTFunc6@LT_HS";
ls:="LTFunc6@LT_LS";
p1:="LTFunc6@LT_P1";
upp:="LTFunc6@LT_UPP";
udd:="LTFunc6@LT_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现“卖”点\n','若明日收盘价>'+numtostrn(upp,2)+',出现“买”点\n');{1.BS点:}
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');{2.短线:}
tr2:=ifs(p1=1,ifs(cross(p1,0),'“买”点','持股'),ifs(cross(1,p1),'“卖”点','持币'));{1.BS点:}
tr3:=ifs(s1=0,'向下,','向上,');{2.短线:}
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';{3.能量级别:}
{102}
c1:=INTPART(cyc(5)*100*0.96)/100;
p2:=intpart(ref(cyc(5),1)*100)/100;
p3:=intpart(ref(cyc(5),1)*0.96*100)/100;
vv:=intpart(min(capital*0.05,ref(ma(vol,34),1))/100);
p40:=intpart(maxcyc*100)/100;
p41:=intpart(ref(MAXCYC,1)*100)/100;
p4:=p1=0 and c>p2 or (ref(vol/100,1)<vv and c>intpart(p2*0.98*100)/100 and vol>min(capital*0.05,ref(ma(vol,34),1)));
p5:=p1=1 and c<min(p3,p41);
p1:=if(p4=1,1,if(p5=1,0,ref(p1,1)));
DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c>0.1,c,'持币');{4.}
DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c<=0.1 and ref(vol/100,1)<vv,c,'明日收盘价超过'+str(c1)+';或收盘价超过 '+str(intpart(c1*0.98*100)/100)+'且成交量大于'+str(vv)+'买入');
DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c<=0.1 and ref(vol/100,1)>=vv,c,'明日收盘价超过'+str(c1)+'买入');
DRAWFLAGTEXT(p1=1 and (c-min(c1,p40))/min(c1,p40)>0.1 ,c,'持股');
DRAWFLAGTEXT(p1=1 and (c-min(c1,p40))/min(c1,p40)<=0.1 ,c,'明日收盘价跌破'+str(min(c1,p40))+'卖出');
{117}
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+' 买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS 点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2. 短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*> '+tr4;
drawflagtext(1,fb,bs);
DRAWTEXTREL(15,0,'变色龙'),COLORYELLOW;



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:买卖点,收盘价,明日,买点,市盈率
关键字:
相关阅读:
  • >>公式-牛熊级别(级别)
    INPUT:n(240,0,10000);最高:hhv(h,n),LINETHICK;//N = 0 是历史最高价幅度:(c/REF(最高,1)-1)*100,LINETHICK;牛能级别:if(幅度>=0,0,if(BETWEEN(幅度,0,-10),1,if(BETWEEN(幅度,-10,-20),2,if(BETWEEN(幅度,-20,-30),3,if(BETWEEN(幅度,...
  • >>公式源码:大智慧主力线柱指标公式(公式)
    A:=VOL*CLOSE;B:=SUM(A,1)SUM(VOL,1);B1:=EMA(B,17);主力趋势:(B-B1)*100B,COLORRED; STICKLINE(主力趋势<0,主力趋势,0,1,0),COLORBLUE;A10:=CROSS(主力趋势,0);无庄:IF(主力趋势<0,主力趋势,0),COLORBLUE,LINETHICK4;STICKLINE(主力...
  • >>指标公式:自用实战MACD飞狐指标(飞狐)
    {自用实战MACD指标}DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));DEA:=EMA(DIFF,9);MACD2:=(2 * (DIFF - DEA));DU0:=CROSS(DIFF,0);UD0:=CROSS(0,DIFF);TDU0:=BARSLAST(DU0);TUD0:=BARSLAST(UD0);DU3:=REF(DU0,1);UD3:=REF(UD0,1);TDU...
  • >>公式源码-趋势操作,只赚不赔(附件 源码 主图 贴图)(主图)
    用法: K线中蓝竖线为KDJ死叉,粉色为金叉, 注意金、死叉出现的高、低位; 根据均线颜色变化,红持股,绿持币; 看清趋势,只赚不赔。本指标准原创,不含未来,不加密,不限时,喜欢的拿去,说明:附件解压导入即可使用,现应坛友之...


  • 友情链接: 庄家 | 宏旺电子 | 海口成人用品 | 股票入门 |5日线 |大智慧公式| 通达信指标公式 | 生活技巧 | 笑话 |