您当前的位置:指标吧通达信指标

公式源码:改进“风险评测”源码有图(通达信)(源码)

时间:2011-05-21 11:51:19 通达信指标公式,通达信指标公式,通达信主图指标公式
摘要: N:=14;M:84;TYP:=(HIGH+LOW+CLOSE)/3;C1:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));C2:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M));注意了结:200,COLORRED;底部区域:-150,COLORGREEN;VARA:=REF(LOW,1); VARB:=SMA(ABS(LOW-VARA),3,1)/SMA(MAX(LOW-VARA,0),3,1)*100; VARC:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);...逃顶,趋势,火焰山,底线,高安改进“风险评测”源码有图(通达信)源码 评测 改进 风险 通达信{风险测评}RSVA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));VAR21:=SMA(RSVA2,9,1)+100;VAR11:=SMA(RSVA1,3,1);VA

{风险测评}
RSVA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));
VAR21:=SMA(RSVA2,9,1)+100;
VAR11:=SMA(RSVA1,3,1);
VAR51:=SMA(VAR11,3,1)+100;
顶底线:=VAR51-VAR21+50;
VAR2:=LLV(LOW,33);
VAR3:=HHV(HIGH,21);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,10)*-1+100;
趋势:=100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1);
STICKLINE(C,100,90,4,0),COLORFFCC33;
STICKLINE(C,90,80,4,0),COLORFF9933;
STICKLINE(顶底线>REF(顶底线,1),20,80,4,0),COLOR9999FF;
STICKLINE(顶底线<REF(顶底线,1),20,80,4,0),COLOR009966;
STICKLINE((趋势>REF(趋势,1) AND 顶底线<REF(顶底线,1)),20,80,4,0),COLOR9999FF;
STICKLINE((趋势<REF(趋势,1) AND 顶底线>REF(顶底线,1)),20,80,4,0),COLOR009966;
STICKLINE(C,20,10,4,0),COLORFF6633;
STICKLINE(C,10,0,4,0),COLORFF3333;
底线:10,COLORWHITE;
顶线:90,COLORWHITE;
趋势线:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),LINETHICK2,COLORBLUE;
当前安全度:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),CIRCLEDOT,LINETHICK2,COLORRED;
DRAWTEXT(CURRBARSCOUNT=6,5,'高安全区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,15,'安全区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,45,'绿区持币'),COLORFFC000;
DRAWTEXT(CURRBARSCOUNT=6,50,'(投资区)'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,55,'粉区持股'),COLORFFC000;
DRAWTEXT(CURRBARSCOUNT=6,85,'风险区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,95,'高风险区'),COLORWHITE;
{强拉升}
Y1:=LLV(L,17);
Y2:=SMA(ABS(L-REF(L,1)),17,1);
Y3:=SMA(MAX(L-REF(L,1),0),17,2);
Q:=-(EMA(IF(L<=Y1,Y2/Y3,-3),1));
STICKLINE(CROSS(Q,0),15,0,4,0), , COLORYELLOW;
强拉升: IF(CROSS(Q,0),1,0),COLORYELLOW;
Q1:= (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00,LINETHICK2;
STICKLINE(CROSS(Q1,-24),20,0,4,0), , COLORMAGENTA;
加强拉升: IF(CROSS(Q1,-24),1,0),COLORMAGENTA;
VAR22:=EXPMA(EXPMA(EXPMA((2*CLOSE+HIGH+LOW)/4,4),4),4);
天:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,2));
地:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,1));
STICKLINE(地>天 AND 地<0,10,0,1,0),COLORRED;
开始拉升:STICKLINE(地>天 AND 地<0,10,0,1,0)=1,COLORRED;
{<<波段绝品>>}
VAR1B:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2B:=SMA(VAR1B,9,1)+100;
VAR3B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4B:=SMA(VAR3B,3,1);
VAR5B:=SMA(VAR4B,3,1)+100;
VAR6B:=VAR5B-VAR2B;
趋势1: IF(VAR6B>45,VAR6B-45,0),COLOR00FFFF,LINETHICK2;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,3.5,0 ),COLOR4444FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,2.5,0 ),COLOR5555FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,1.5,0 ),COLOR7777FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,0.5,0 ),COLOR9999FF;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR000033;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR000055;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR000077;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR000099;
STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR0000DD;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR003300;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR005500;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR007700;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR009900;
STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR00DD00;
逃顶:=CROSS(82,RSI);
STICKLINE( 逃顶,逃顶,10,3.5,0),COLORFF5500;
STICKLINE( 逃顶,逃顶,15,2.5,0),COLORFF8800;
STICKLINE( 逃顶,逃顶,20,1.5,0),COLORFFAA00;
STICKLINE( 逃顶,逃顶,25,0.5,0),COLORFFCC00;
STICKLINE( 逃顶,逃顶,30,0.1,0),COLORFFFF00;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
强弱线:50,COLORGREEN,POINTDOT;
DRAWICON(BBUY,20,1);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),10,15);
DRAWTEXT(CROSS(82,VARR1),35,'逃'),COLORYELLOW;



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:逃顶,趋势,火焰山,底线,高安
关键字:
相关阅读:
  • >>公式-巧算庄家的持仓量和成本(tdx)(庄家)
    MACD:="MACD.MACD#WEEK";起点0:=BARSLAST(MACD<0);起点:=IF(MACD<0,REF(起点0,BARSLAST(MACD>0)),起点0);STICKLINE((起点=1),HHV(H,160),LLV(L,160),0,0);累计量:=SUM(IF(MACD>0,V,0),起点+1);时段换手:累计量/CAPITAL*100,NODRAW;控...
  • >>源码-黄金买点---波动仪出品(买点)
    {黄金买点---波动仪出品}zz:=(o+h+l)/3;hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;xxb:=CLOSE*VOL;xxbym:EMA((EMA(xxb,3)/EMA(VOL,3)+EMA(xxb,6)/EMA(VOL,6)+EMA(xxb,12)/EMA(VOL,12)+EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINET...
  • >>[指标]大智慧趋势先机指标公式(先机)
    M1:=WINNER( MA(CLOSE,1))*200;{同花顺公式网选编}M2:=WINNER(MA(CLOSE,20))*200;Var1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;Var2:=SMA(Var1,3,1);Var3:=SMA(Var2,3,1);Var4:=3*Var2-2*Var3;Var5:=LLV(LOW,5);Var6:...
  • >>[指标]明天变盘公式(公式)
    N:=1200;高:=REF(HHV(H,N),3); 低:=REF(LLV(L,N),3);H19:=高-(高-低)*0.191; H38:=高-(高-低)*0.382; H中:=高-(高-低)*0.5; H61:=高-(高-低)*0.618; H80:=高-(高-低)*0.809;顶:REFDATE(高,DATE),COLORWHITE,CROSSDOT;%19.8:REFDAT...


  • 友情链接: 庄家 | 宏旺电子 | 海口成人用品 | 股票入门 |5日线 |大智慧公式| 通达信指标公式 | 生活技巧 | 笑话 |